PHP 스위치 – 1.프로그램 소개

PHP스위치(phpswitch)는 윈도우 XP에서 PHP 버전을 수시로 바꾸어가며 APM(Apache, PHP, MySQL)을 사용할 수 있도록 자동으로 설치, 설정해주는 프로그램입니다.

< PHP스위치 프로그램 >

그러나 다른 APM 설치 툴처럼 웹서비스용으로 만들어진 것이 아니고 개발자들이 라이브러리를 개발하면서 여러 PHP 버전의 호환성을 테스트할 수 있도록 PHP 버전을 손쉽게 바꾸어 줄 수 있도록 만들어 진 것입니다. 따라서 Apache, MySQL, PHP, Zend Optimizer 외에 OpenSSL 등을 설치하지 않습니다.

보통의 윈도우 APM 설치와 같이 각 바이너리 소스를 인스톨하는 것이 아니라 압축파일을 설치하려는 곳에 풀어준 뒤 PHP스위치 실행파일인 phpswitch.exe를 실행하여 메뉴에서 필요한 설치작업을 수행합니다.

PHP스위치 프로그램은 윈도우 프로그램이 아니라 도스(CMD)창을 이용하는 도스 프로그램입니다.

포함된 APM 소스는 아래와 같습니다.

  • MySQL 4.0.26
  • Apache 1.3.41 for PHP 4
  • Apache 2.0.63 for PHP 5
  • PHP 4.0.6, 4.3.0, 4.4.6, 5.0.0, 5.1.0, 5.2.6
  • Zend Optimizer v2.5.7 for PHP 4.0.x, 4.1.x, 4.3.x, 5.0.x
  • Zend Optimizer v3.3.3 for PHP 4.2.x, 4.4.x, 5.1.x, 5.2.x

Zend Optimizer도 ZendOptimizer-x.x.x-Windows-i386.exe과 같은 인스톨 파일을 통해 설치하는 것이 아니라 압축파일 안에 포함된 DLL(Dynamic Link Library) 파일을 php.ini에서 설정하여 링크시키기만 합니다. 따라서 Zend Optimizer 버전에 따라 정상적으로 동작하지 않는 PHP 버전 들이 있습니다. 이러한 이유로 Zend Optimizer v2.5.7과 v3.3.3 버전을 PHP 버전에 따라 선택하여 사용합니다.

본 프로그램은 사용에 아무런 제한이 없는 프리웨어입니다. PHP스위치는 제가 공개라이브러리를 개발하면서 각 PHP 버전의 호환성을 확인하기 위하여 사용해 오던 것을 그냥 공개하는 것인지라 제가 사용하고 있는 Windows XP 외의 다른 시스템에서 PHP스위치가 정상적으로 동작하는지는 실험하지 않았습니다.

답글 남기기